Tuesday, December 23, 2008

Eclipse Update Problem

For the last month or so, Eclipse has been bugging me to update. Like the fool that I am, every couple of weeks, I click the update icon and get this Available Updates window which seems full of all sorts of potential nifty bug fixes and feature additions.



After running for a few seconds, I'm unhelpfully presented with this dialog:



Clicking on the Details button, I get this dialog which does nothing to help me resolve the issue.



Dear Eclipse, why do you tease me so?

7 comments:

David Carver said...

You might want to try just installing the Eclipse Platform updates. There are a bunch of Provisioning fixes in there...or better, you might just want to download Eclipse 3.4.1 and then install the packages you need.

Jon Scott Stevens said...

I am running 3.4.1 already.

Jon Scott Stevens said...

Every time I try to uncheck one of the items to install, it pegs one of my cpus at 100% and takes 30 seconds to compute all the missing dependencies.

David Carver said...

It looks like you are having problems with the WTP update site. So I would suggest opening a bug with WTP and see if they can duplicate the problem and get it corrected.

Jon Scott Stevens said...

See, that kind of bugs me. I have a default J2EE install that I've only added Subclipse to. I have made no other relevant modifications to it. I can't see how others aren't having the same problem. Instead of spending more time opening a bug and tracking it, I'll just download another 150meg copy of Eclipse and try to use that instead.

Anton Tagunov said...

Hi! Yes I feel your pain, these bugs are annoying. You must already know this but if you don't - in your workspace there a .metadata folder and .log file in it. It will often contain exception stack trace when Eclipse frontend displays an error message. Not that would help you a lot but this will a tangible artifact that you can attach to a bug report - should you like to do that.

BTW I've never tried to update my Eclipse to a new version. I always download anew and the re-download my plugins. Such low my confidence is that update word work and yield a stable system...

Diego Pacheco said...

I'm using the eclipse 3.4.1 aka Ganymede SR1. I also had this same error, I deleted the folder 'metadata' in the workspace, I created another, did the update and worked.